skip to content »

ec-clan.ru

Diablo iii launcher stuck at updating setup files

diablo iii launcher stuck at updating setup files-71

os=win&version=LIVE&game Program=BATTLENET_APP/Battle.net-Setup.exe" Setup Is="$POL_System_Tmp Dir/Battle.net-Setup.exe" # Removed the DVD option as it has a really old installer and game files and isn't worth using IMHO POL_Debug_Message "Creating Wine Install ------------------------" POL_Wine_Select Prefix "$PREFIX" POL_Wine_Prefix Create "$WORKING_WINE_VERSION" POL_Debug_Message "Setting Wine Variables -----------------------" Set_OS "winxp" # Updated Overrides, many of wine's dlls are up to spec now and diablo has even removed some of their own.POL_Wine_Override DLL "native,builtin" "vcruntime140" POL_Wine_Override DLL "native,builtin" "msvcp140" POL_Wine_Override DLL "native,builtin" "ucrtbase" # Updated dependancies, Most no longer needed due to wine 2.0 (07-APR-2017) POL_Call POL_Install_corefonts POL_Call POL_Install_Physx #POL_Call POL_Install_ie8 #IE8 for future alternative Blizzard App display fix (28-JUN-2017) POL_Debug_Message "Running Install File -------------------------" POL_Wine_Wait Before "$TITLE" POL_Wine "$Setup Is" POL_Setup Window_VMS "1024" POL_System_Tmp Delete POL_Debug_Message "Creating Shortcut ----------------------------" POL_Shortcut "Launcher.exe" "$TITLE" "" "" "Game" POL_Debug_Message "Install Completed ----------------------------" POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete!

diablo iii launcher stuck at updating setup files-26diablo iii launcher stuck at updating setup files-39

Then login to Blizzard and install the Diablo III game files.')" POL_Setup Window_Close exit 0Hi, this is my 32-bit install file.Then login to Blizzard and install the Diablo III game files.')" POL_Setup Window_Close exit [email protected]@ -89,7 89,7 @@ POL_Debug_Message "Install Completed ----------------------------" -POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete')\n\n$(eval_gettext 'IMPORTANT: Login to the Blizzard app by using the email and password entries near the bottom of the login window, not the nice looking ones near the top.Then login to Blizzard and install the Diablo III game files.')" POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete')\n\n$(eval_gettext 'IMPORTANT: Login to the Blizzard app by using the email and password entries near the bottom of the login window, not the nice looking ones near the top./usr/bin/env playonlinux-bash # Date : (2017-06-28) # Wine version used : 2.11-staging # Distribution used to test : Ubuntu 17.04 # NVidia Ge Force GTX 960/PCIe/SSE2 # AMD FX(tm)-6300 Six-Core Processor × 6 # NVidia GTX 750Ti # CHANGELOG # [Some Guy42] (28-JUN-2017) # Wine 2.5-staging = winxp # fixes blizzard app display bug but complains of future support # futre alternative is ie8 but doesnt solve initial login window issue # my testing shows winxp gives better performance ( ~10fps) # [Some Guy42] (09-APR-2017) # Wine 2.0-rc3-staging = 2.5-staging # 2.5 has many preinstalled components and should make the install simpler/more stable # Blizzard app v1.8.0.8600 (formerly Battle.net) # Diablo 3 Patch 2.5.0.44247 # [Ravon TUS] (06-JAN-2017) # added Dependencies to improve the install # Wine 1.7.15 = 2.0-rc3-staging # Battle.Net Patch 1.5.2.8180 # Diablo 3 Patch 2.4.3 (64-bit Client) # NVidia Ge Force GTX 960/PCIe/SSE2 # AMD FX(tm)-6300 Six-Core Processor × 6 # [Some Guy42] (2016-11-22) # Wine 1.7.15 = 1.7.15 (Dark Nekros) # [Super Plumus] (2013-06-08 17-14) # gettext clean [ "$PLAYONLINUX" = "" ] && exit 0 source "$PLAYONLINUX/lib/sources" TITLE="Diablo III" WORKING_WINE_VERSION="2.11-staging" EDITOR="Blizzard Entertainment Inc." EDITOR_URL=" PREFIX="Diablo III_32" AUTHOR="Some Guy42, Ravon TUS, and the POL Community" POL_Get Setup Images " " "$TITLE" POL_Setup Window_Init POL_Setup Window_Set ID 1195 POL_Debug_Init POL_Debug_Message "Starting Install -----------------------------" POL_Setup Window_presentation "$TITLE" "$EDITOR" "$EDITOR_URL" "$AUTHOR" "$PREFIX" POL_System_Set Arch "x86" POL_System_Tmp Create "$PREFIX" POL_Setup Window_message "$(eval_gettext 'NOTICE: This will install the Blizzard application first and configure the settings for Diablo 3.')" POL_Debug_Message "Downloading Install File -------------" cd "$POL_System_Tmp Dir" # now has a universal installer with language selection at start POL_Download "https:// Installer For Game?POL_Wine_Override DLL "native,builtin" "vcruntime140" POL_Wine_Override DLL "native,builtin" "msvcp140" POL_Wine_Override DLL "native,builtin" "ucrtbase" # Updated dependancies, Most no longer needed due to wine 2.0 (07-APR-2017) POL_Call POL_Install_corefonts POL_Call POL_Install_Physx POL_Debug_Message "Running Install File -------------------------" POL_Wine_Wait Before "$TITLE" POL_Wine "$Setup Is" POL_Setup Window_VMS "1024" POL_System_Tmp Delete POL_Debug_Message "Creating Shortcut ----------------------------" POL_Shortcut "Launcher.exe" "$TITLE" "" "" "Game" POL_Debug_Message "Install Completed ----------------------------" POL_Setup Window_message "$(eval_gettext 'Blizzard application Installation Complete')\n\n$(eval_gettext 'IMPORTANT: Login to the Blizzard app by using the email and password entries near the bottom of the login window, not the nice looking ones near the top.

You may also want to check the box for Keep Me Always Loged In.

The easiest way to fix it is to set the os to winxp. Greetings, It took me a while to get this one going - Battle.

Net v1.8.0.860 and Diablo III v2.50 (Season 10), because I crashed my OS. /usr/bin/env playonlinux-bash # Date : (2017-04-07) # Wine version used : 2.4-staging # Distribution used to test : Ubuntu 16.04 LTS/Kernel 4.10.8/NVidia GTX960 # Battle.

/usr/bin/env playonlinux-bash # Date : (2017-04-07) # Wine version used : 2.4-staging # Distribution used to test : Ubuntu 16.04 LTS # NVidia Ge Force GTX 960/PCIe/SSE2 # AMD FX(tm)-6300 Six-Core Processor × 6 # CHANGELOG # [Some Guy42] (09-APR-2017) # Wine 2.0-rc3-staging = 2.5-staging # 2.5 has many preinstalled components and should make the install simpler/more stable # Blizzard app v1.8.0.8600 (formerly Battle.net) # Diablo 3 Patch 2.5.0.44247 # [Ravon TUS] (06-JAN-2017) # added Dependencies to improve the install # Wine 1.7.15 = 2.0-rc3-staging # Battle.

Net Patch 1.5.2.8180 # Diablo 3 Patch 2.4.3 (64-bit Client) # NVidia Ge Force GTX 960/PCIe/SSE2 # AMD FX(tm)-6300 Six-Core Processor × 6 # [Some Guy42] (2016-11-22) # Wine 1.7.15 = 1.7.15 (Dark Nekros) # [Super Plumus] (2013-06-08 17-14) # gettext clean [ "$PLAYONLINUX" = "" ] && exit 0 source "$PLAYONLINUX/lib/sources" TITLE="Diablo III" WORKING_WINE_VERSION="2.5-staging" EDITOR="Blizzard Entertainment Inc." EDITOR_URL=" PREFIX="Diablo III_32" AUTHOR="Ravon TUS, Some Guy42 and the POL Community" POL_Get Setup Images " " "$TITLE" POL_Setup Window_Init POL_Setup Window_Set ID 1195 POL_Debug_Init POL_Debug_Message "Starting Install -----------------------------" POL_Setup Window_presentation "$TITLE" "$EDITOR" "$EDITOR_URL" "$AUTHOR" "$PREFIX" POL_System_Set Arch "x86" #POL_System_Set Arch "amd64" POL_System_Tmp Create "$PREFIX" POL_Setup Window_message "$(eval_gettext 'NOTICE: This will install the Blizzard application first and configure the settings for Diablo 3.')\n\n$(eval_gettext 'The Blizzard app install may take longer than expected to continue to the next window, but it works in most cases.

For example if it appears not to continue at the Installation Location window, wait a couple minutes and try clicking the Continue button again.')" POL_Debug_Message "Downloading Install File -------------" cd "$POL_System_Tmp Dir" # now has a universal installer with language selection at start POL_Download "https:// Installer For Game?